FlashDevelop 3.0.0 RC2 released

사용자 삽입 이미지
Post FlashDevelop 3.0.0 RC2 released
This release took long because we wanted to implement all features that might effect the user files and therefore once again, previous FlashDevelop versions are incompatible with this one. Sorry for the trouble. As we are now approaching the final release of FlashDevelop 3, this release is the last feature release. We will now focus only to make FlashDevelop rock solid. We also try to write some documentation about FD basics and all contributors are welcome to join us.

About FlashDevelop:



* New events and comments added for plugin developers.
* New installable filetype (*.fdz) to deploy files in FD world.
* Slightly revised snippet editor and now it’s directly included in FD.
* New FlashLogViewer plugin which basicly is an extended version of Andrew Lucking’s FDTracer plugin.
* New dynamic arguments and a dialog to fill them just prior to template creation (was Enhanced Arguments plugin by Mike McMullin).
* Added an option to save UTF-8 files without BOM. To get this fully working like FB set the callback encoding to UTF-8.
* Many new options to the UI and processes in FlashDevelop.
* Newly generated fixed completion intrisic files.
* Updated AIR 1.5 templates.

+ Lots of bug fixes and other small improvements. :)

Future plans:

* Finish the AS3 debugger, investigate profiling.
* Implement class imports reorganisation and packages refactoring.
* Evaluate the possible cross-platform implementation.
* Add HTML/JS projects, investigate Jangaroo AS to JS compilation.
* Make the MXML completion actually smart.
* Integrate properly with Haxe compiler.


* Those who have customized their menus or syntax files previously need to review the customization notes from the wiki. View the documentation.
Backup your user files and uninstall FlashDevelop with setting files. From this point on we’ll preserve the user files so please customize the files again based on this release.
Get Adobe Flex 3 SDK. The free Flex SDK (2 or 3) is required for ActionScript 3 development if you don’t use Flash CS3.
Get the debug Flash Player (You need: Projector and ActiveX)
* Java 1.6+ is required for the Flex compiler (ActionScript 3).

:!: If you think the program is good, please donate some money for this project. :!:


Built from rev. 398
Download FlashDevelop 3.0.0 RC2

(주)리화이트 대표 / CEO & Founder

Next ArticleCreating a Papervision BaseTemplate (by FlashDevelop)